Shared Cluster Webhosting Outage
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 16:17 GMT
Update
Our engineers have identified and resolved the issue and will continue to monitor the platform.

We have tested a number of affected sites and have confirmed that they are now back online.
Posted Mar 28, 2024 - 16:07 GMT
Investigating
Our engineers are currently investigating affecting a number of sites on our cluster hosting platform.

Affected sites will show a message indicating that the site cannot be reached or is refusing the connection. We will provide more updates as and when they become available.
Posted Mar 28, 2024 - 15:51 GMT
This incident affected: Hosting (Webhosting).