Service Outage - Support Ticket System Offline

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Dec 08, 2025 - 15:20 GMT

Identified

Our email support ticket system is currently down. The ticket portal & chat support are inaccessible. For urgent issues, please call our support line. We are working to restore this service.
Posted Dec 08, 2025 - 14:01 GMT
This incident affected: Customer Services (Email Support).