Wordpress Hosting - Site availability issues

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Aug 17, 2026 - 13:18 BST

Monitoring

We have eliminated the disruption for almost everyone affected. We are working on a quick solution and apologise for any inconvenience this may cause.
Posted Aug 17, 2026 - 12:58 BST

Identified

We are still working on resolving the technical issue. Our apologies for the inconvenience caused.
Posted Aug 17, 2026 - 05:12 BST

Update

We are continuing to investigate this issue.
Posted Aug 16, 2026 - 13:19 BST

Investigating

We are currently experiencing issues with some sites hosted using our Hosting for WordPress packages. Engineers are currently investigating the issue and we'll continue to update once more information is available.
Posted Aug 16, 2026 - 13:18 BST
This incident affected: Hosting (WordPress Hosting).