Service Outage - Webmail Unavailable

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Oct 27, 2025 - 15:32 GMT

Identified

We are aware that our Webmail interface is currently unavailable. Customers attempting to log in may receive an error. Accessing email via desktop or mobile clients (IMAP/POP3) is unaffected. Our team is working to restore the Webmail service now.
Posted Oct 27, 2025 - 15:07 GMT
This incident affected: Email (Webmail Interface, Sending Mail).