Email – some mail clients may be unable to connect

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Jun 11, 2026 - 15:06 BST

Investigating

We're currently investigating an issue affecting Email for customers using mail clients. You may be unable to connect your mailbox, or send and receive Email via your mail client.

Fasthosts Webmail & Outlook Web App (OWA) are unaffected, you can continue to send and receive Email as normal.

No Emails will be lost during this time, and we're working to restore full functionality as quickly as possible. We'll update you as soon as we have more information.
Posted Jun 11, 2026 - 13:14 BST
This incident affected: Email (Sending Mail, Receiving Mail).