Service Outage - Service Interruption for Shared Hosting

Incident Report for Fasthosts

Resolved

The issue has been resolved. Our apologies for the inconvenience caused.
Posted Aug 14, 2026 - 16:36 BST

Identified

We are experiencing a service interruption on our shared hosting. Some websites on this platform are currently offline. This is our highest priority, and our engineers are actively working to restore service.
Posted Aug 14, 2026 - 15:38 BST
This incident affected: Hosting (Webhosting).