Disruption in several Control Panel areas

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Sep 15, 2026 - 11:06 BST

Identified

During this time, configurations in some areas of your Fasthosts control panel may be limited. Our engineering team is working to restore access with the highest priority. We sincerely apologise for this disruption.
Posted Sep 15, 2026 - 10:37 BST
This incident affected: Control Panels (Control Panel).