.UK Registry maintenance

Scheduled for Oct 23, 10:00 - 12:00 BST

Update

We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2025 - 08:11 BST

Scheduled

Our .UK registry will be performing essential maintenance between 10:00-12:00 BST on 23rd October. During this maintenance customers may experience intermittent connection issues when registering, renewing and updating .UK domains.
Posted Sep 23, 2025 - 08:10 BST
This scheduled maintenance affects: Domains (Registries).