Website Builder Intermittent Outages

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Feb 09, 2025 - 15:46 GMT

Monitoring

We have identified the cause of the outage, and the sites are no longer timing out. We are continuing to monitor the situation closely.
Posted Feb 09, 2025 - 14:34 GMT

Investigating

Customers who use Website Builders are experiencing timeout errors when attempting to load there site, We are currently investigating the issue.
Posted Feb 09, 2025 - 13:45 GMT
This incident affected: Hosting (Website Builders).