Standard POP3/IMAP Mailbox Server Errors
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Mar 18, 2024 - 18:03 GMT
Update
We are continuing to investigate this issue. Some customers may also experience issues with mail clients such as Outlook.
Posted Mar 18, 2024 - 17:20 GMT
Update
We are continuing to investigate this issue.
Posted Mar 18, 2024 - 16:38 GMT
Investigating
Our engineers are investigating an issue where some users may see a generic error or server error message when attempting to login to or use our standard webmail platform. Access via email clients such as Outlook should not be affected.

This issue is only affecting our Standard POP3/IMAP mailboxes. Exchange and Microsoft 365 mailboxes should not be affected.
Posted Mar 18, 2024 - 16:30 GMT
This incident affected: Email (Webmail Interface, Standard Email).