Sending email to Microsoft-hosted email addresses may not be possible

Incident Report for Fasthosts

Resolved

The issue has been resolved. Thank you for your patience and understanding.
Posted Feb 26, 2026 - 12:23 GMT

Monitoring

We apologise to customers who were affected by this disruption. We are working to ensure that similar issues do not occur in the future.
Posted Feb 24, 2026 - 16:12 GMT

Update

We have eliminated the disruption for almost everyone affected.
Posted Feb 19, 2026 - 17:54 GMT

Update

We have eliminated the disruption for some of those affected.
Posted Feb 17, 2026 - 13:07 GMT

Identified

Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience you may be experiencing.
Posted Feb 17, 2026 - 10:21 GMT
This incident affected: Email (Sending Mail).