Sending email to Microsoft-hosted email addresses may not be possible

Incident Report for Fasthosts

Resolved

The issue has been resolved. Thank you for your patience and understanding.
Posted Apr 28, 2026 - 09:25 BST

Update

We have eliminated the disruption for almost everyone affected. We are monitoring the situation to ensure that the issue does not reoccur.
Posted Apr 27, 2026 - 18:27 BST

Monitoring

We have successfully minimised the disruption and are working to completely resolve it as soon as possible.
Posted Apr 27, 2026 - 15:32 BST

Identified

Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

Please accept our apologies for any inconvenience you may be experiencing.
Posted Apr 27, 2026 - 11:54 BST
This incident affected: Email (Sending Mail).