Website Builder Timeouts

Incident Report for Fasthosts

Resolved

Websites are now resolving and we are investigating the root cause issue of the incident
Posted Feb 10, 2025 - 12:14 GMT

Investigating

Customers who use Website Builder products are experiencing timeout errors when attempting to load websites, this is a re occurrence of the issue resolved earlier today, We are currently investigating the issue.
Posted Feb 10, 2025 - 11:04 GMT
This incident affected: Hosting (Website Builders).