Cloud panel and services temporarily unavailable

Incident Report for Fasthosts

Resolved

This incident is now resolved and an investigation into the root cause is ongoing
Posted May 21, 2025 - 14:03 BST

Investigating

We are currently experiencing an issue affecting our Cloud services - Cloud/Bare Metal servers, Load balancers, private & public networks, shared storage & VPN services, may be unavailable at this time, we are investigating the issue and hope to have this resolved as soon as possible.
Posted May 21, 2025 - 11:20 BST
This incident affected: Servers (Cloud Servers).