Fasthosts Control Panel timeout errors

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Jan 28, 2025 - 11:44 GMT

Investigating

Customers accessing the control panel may experience timeout errors along with issues sending support codes. Our engineers are aware of this issue and are working on it as a priority.
Posted Jan 28, 2025 - 11:17 GMT
This incident affected: Control Panels (Control Panel).