Spamhaus Blacklist Issue
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 09:44 GMT
Investigating
Some users are currently experiencing bounebacks when sending mail from our shared platform.

The bounceback states that the IP 213.171.216.45 is listed with Spamhaus however their online tools indicate the IP is not currently blacklisted.

Our engineers are in contact with Spamhaus in order to investigate and resolve this issue.
Posted Mar 27, 2024 - 14:13 GMT
This incident affected: Email (Standard Email, Microsoft Exchange Email, Sending Mail).