Access to Cloud Panel may not be possible.

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Apr 16, 2026 - 15:18 BST

Identified

Some customers may experience issues accessing their Cloud Panel.
Posted Apr 16, 2026 - 10:41 BST
This incident affected: Servers (Cloud Servers).