Email Forwarding Issue

Incident Report for Fasthosts

Resolved

This incident is now resolved.
Posted Jun 04, 2025 - 05:43 BST

Monitoring

We have implemented a fix for the issue. However, we are still monitoring, and it will take a few hours for queued mail to complete processing the backlog.
Posted Jun 04, 2025 - 03:16 BST

Investigating

We are receiving reports that emails being forwarded are not reaching their destination. We are looking into what is occurring.
Posted Jun 03, 2025 - 20:47 BST
This incident affected: Email (Sending Mail).