Some email logins failing

Incident Report for Fasthosts

Resolved

Webmail logins should now be working for all customers.
Posted Dec 14, 2025 - 09:53 GMT

Investigating

Webmail logins are failing for some mailboxes, giving an error "LGI-0003".
Our engineers are working to resolve this.
Posted Dec 14, 2025 - 08:21 GMT
This incident affected: Email (Webmail Interface).