We have eliminated the disruption for almost everyone affected.
Posted Jul 06, 2026 - 11:51 BST
Update
Microsoft has confirmed mitigations on their side, but we're still seeing blocks. These happen when Microsoft detects traffic it considers higher than expected and applies restrictions outside of our control. Our engineering team is actively working to optimise mail flows and reduce the chance of these blocks. We're in regular contact with Microsoft to push for a lasting fix, and this remains a top priority.
Posted Jul 03, 2026 - 08:10 BST
Identified
We have found the cause for the disruption and are working on resolving it.
Posted Jul 02, 2026 - 14:43 BST
Update
We are still working on resolving this issue. Our apologies for the inconvenience caused.
Posted Jul 02, 2026 - 07:41 BST
Monitoring
The affected IP address has been unblocked. Now that service has been restored and the IP address's reputation is being re-established, it may take up to 24–48 hours for the change to fully propagate across our systems. During this time, some email sending limits may still remain in effect. Thank you for your patience and understanding.
Posted Jun 30, 2026 - 18:09 BST
Update
We have eliminated the disruption for some of those affected.
Posted Jun 30, 2026 - 14:04 BST
Identified
Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.
We are in contact with Microsoft to request de-listing.
Please accept our apologies for any inconvenience you may be experiencing.