Reduced support availability

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 15:31 BST

Investigating

One of our support teams are currently impacted by an earthquake. Calls are being routed to an alternative support team, however it may take longer for our agents to answer calls and respond to queries.
Posted Sep 30, 2025 - 15:16 BST
This incident affected: Customer Services (Phone Systems, Chat Support, Email Support).