AI Receptionist Settings Temporarily Unavailable

Incident Report for Fasthosts

Update

We are continuing to investigate this issue.
Posted Jul 07, 2026 - 13:06 BST

Investigating

Access to configure AI Receptionist in the Control Panel may be temporarily unavailable. The AI Receptionist service itself will continue to work as normal.
Posted Jul 07, 2026 - 12:59 BST
This incident affects: AI Receptionist.