Cloud Server Host Node Failure

Incident Report for Fasthosts

Update

We are still working on resolving the technical issue. Thank you for your patience.
Posted Jul 07, 2026 - 10:36 BST

Update

We have eliminated the disruption for almost everyone affected.
Posted Jul 06, 2026 - 17:00 BST

Update

We are continuing to work on a fix for this issue.
Posted Jul 06, 2026 - 13:47 BST

Identified

We are currently investigating instances of performance degradation in job processing which is affecting Virtual Private Servers (VPS) and CloudNX servers on our platform. Our engineers are currently working on resolving this issue as a top priority.
Posted Jul 06, 2026 - 13:28 BST
This incident affects: Servers (Cloud Servers).