Email Access & Delivery Issues
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 15:04 BST
Monitoring
Our engineers have taken action to address these issues and we are now seeing webmail logins and email client connections working again.

We are continuing to monitor mail queues but they are now back within expected margins and email should begin to be received and delivered in a timely manner.
Posted Apr 09, 2024 - 14:00 BST
Investigating
Our engineers are currently investigating an issue where customers are unable to access webmail and customers using email clients may see delays with sending and receiving emails.

A partial fix has been implemented and some logins may now be working, and queued mail delivery should improve. We will continue to work on fully resolving the issue.
Posted Apr 09, 2024 - 13:40 BST
This incident affected: Email (Standard Email, Microsoft Exchange Email, Sending Mail, Receiving Mail).