Support Hotline cannot be reached

Incident Report for Fasthosts

Resolved

The issue has been resolved. Our apologies for the inconvenience caused.
Posted Jul 07, 2026 - 10:29 BST

Identified

Due to a technical disruption, the Support hotline is temporarily unavailable. As an alternative, you can use 01452 947421.

We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding.
Posted Jul 07, 2026 - 09:42 BST
This incident affected: Customer Services (Phone Systems).