Sending email to Microsoft-hosted email addresses may not be possible

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 11:48 GMT

Update

Our technicians are actively working to resolve the issue. Thank you for your patience and we apologize for the inconvenience caused.
Posted Jan 27, 2026 - 21:10 GMT

Identified

Some emails sent to Microsoft-hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience you may be experiencing.
Posted Jan 27, 2026 - 11:01 GMT
This incident affected: Email (Standard Email, Sending Mail).