Service Outage - Webmail Unavailable

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Mar 13, 2026 - 10:35 GMT

Identified

We are aware that our Webmail interface is currently unavailable. Customers attempting to log in will receive an error. Our team is working to restore the Webmail service now.
Posted Mar 13, 2026 - 10:04 GMT
This incident affected: Email (Webmail Interface).