FTP, Webmail & Legacy Web Server issues

Incident Report for Fasthosts

Resolved

The issue affecting webmail has now been resolved and we are monitoring this, apologies for any inconvenience this has caused.
Posted May 08, 2025 - 10:16 BST

Update

The issue affecting our legacy web servers and FTP products should now be resolved, we are still working on returning webmail to operational status
Posted May 08, 2025 - 09:20 BST

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 09:18 BST

Investigating

We are currently experiencing an issue with a database providing services to our FTP , webmail & Legacy web server products , this is being investigated currently and we hope to have this resolved very shortly.
Posted May 08, 2025 - 09:17 BST
This incident affected: Email (Webmail Interface) and Hosting (Webhosting).