Investigating Incoming Email Delays

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Mar 17, 2026 - 13:38 GMT

Identified

We are investigating an issue affecting incoming email delivery. Some users may not see new messages in their inboxes at this time. Our team is working to restore service as quickly as possible.

Potential Cause: A backend delivery service interruption.
Posted Mar 17, 2026 - 12:21 GMT
This incident affected: Email (Standard Email, Receiving Mail).