Wordpress Sites Unavailable

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted May 22, 2026 - 12:09 BST

Identified

A small number of WordPress websites are currently failing to load. Our engineers are investigating.
Posted May 22, 2026 - 10:27 BST
This incident affected: Hosting (WordPress Hosting).