Critical - Outbound Mail (SMTP) Service Unavailable

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Dec 02, 2025 - 15:16 GMT

Update

We are still working on resolving the technical issue.
Posted Dec 02, 2025 - 11:43 GMT

Identified

We are aware of a critical issue preventing all customers from sending outbound email via our SMTP servers. Messages will remain in your outbox and fail to send. This is a top priority for our engineering team
Posted Dec 02, 2025 - 08:50 GMT
This incident affected: Email (Sending Mail).