Webmail Intermittently Unavailable

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Feb 19, 2025 - 12:31 GMT

Monitoring

Our engineers have implemented a fix and our webmail facilities should now be accessible without error. We will continue to monitor the platform.
Posted Feb 19, 2025 - 11:53 GMT

Investigating

We are currently investigating an issue with our webmail service for our shared mail platform.

Users trying to access their mail via webmail.fasthosts.co.uk or webmail.livemail.co.uk may get an error whilst the issue is ongoing.
Posted Feb 19, 2025 - 11:11 GMT
This incident affected: Email (Webmail Interface).