Email Delivery Issue – Yahoo and Sky Mail

Incident Report for Fasthosts

Update

We are still working on resolving this issue. More information will follow soon.
Posted Jan 21, 2026 - 02:05 GMT

Update

We are still working on resolving the technical issue. Thank you for your patience.
Posted Jan 20, 2026 - 03:20 GMT

Identified

We are aware of an issue impacting email forwarding to Yahoo and Sky Mail addresses. Some customers may experience failed deliveries.

Our Mail Operations team is investigating and will share updates as progress is made.
Posted Jan 19, 2026 - 16:37 GMT
This incident affects: Email (Sending Mail).