Website Builder 503 Errors

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Apr 15, 2025 - 12:45 BST

Investigating

Customers are experiencing 503 errors when trying to access their Website Builder website. Our engineers are aware of this issue and are working on it as a priority.
Posted Apr 15, 2025 - 12:09 BST
This incident affected: Hosting (Website Builders).