Control Panel Errors
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Apr 09, 2024 - 15:04 BST
Monitoring
Our engineers have implemented a number of fixes to resolve the various issues with the control panel that had been reported.

We are no longer seeing any alerts or reports of issues but will continue to monitor the platform
Posted Apr 09, 2024 - 14:22 BST
Investigating
Following this mornings Control Panel maintenance, users may experience errors within the control panel and some content may not be displaying correctly.

Our engineers are aware and are working to fix these issues as a top priority.
Posted Apr 09, 2024 - 10:25 BST
This incident affected: Control Panels (Control Panel).