Support Chat Unavailability

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 08:59 GMT

Investigating

When starting a chat with our support team, some customers may see a notice that “the team you’re trying to reach is currently unavailable.” This is due to severe weather conditions that have temporarily reduced staff availability. We apologize for any inconvenience.

If your issue isn’t urgent, please email us at support@fasthosts.com or call 0333 0142 700. Thank you for your understanding.
Posted Nov 06, 2025 - 14:37 GMT
This incident affected: Customer Services (Chat Support).