Server Outage
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 04:40 GMT
Update
We are continuing to investigate this issue.
Posted Mar 19, 2024 - 02:11 GMT
Investigating
A small number of virtual and bare metal servers are currently offline. We are investigating as a priority.
Posted Mar 19, 2024 - 01:47 GMT
This incident affected: Servers (Bare Metal, Cloud Servers, Dedicated Servers, Virtual Private Servers).