Connectivity issues in email clients
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Nov 23, 2023 - 13:57 GMT
Monitoring
Our engineers have taken action to resolve the issue and will continue to monitor the platform.
Posted Nov 23, 2023 - 13:06 GMT
Investigating
A number of customers are experiencing issues connecting to their mailbox in email clients such as outlook. The issue may cause the software to repeatedly prompt for your credentials or serve a generic error message.

Our engineers have been made aware of the issue and are now investigating.

The webmail facility is still working for all customers who have reported issues and can be used in the interim: https://login.livemail.co.uk/
Posted Nov 23, 2023 - 11:55 GMT
This incident affected: Email (Standard Email).