Phone Lines Unavailable

Incident Report for Fasthosts

Resolved

We have confirmed with our provider, and after monitoring stability, that our usual support telephone numbers are now available.
Posted Feb 16, 2025 - 12:35 GMT

Update

Our usual telephone numbers are currently unavailable while we investigate an issue affecting our Telephone provider , please use
44 1452 947421 for any queries until this issue is resolved.
Posted Feb 15, 2025 - 11:22 GMT

Investigating

Our usual telephone numbers are currently unavailable while we investigate an issue affecting our Telephone provider , please use
44 1452 947421 for any queries until this issue is resolved.
Posted Feb 15, 2025 - 11:21 GMT
This incident affected: Customer Services (Phone Systems).