Reduced Support Availability - Power Outage

Incident Report for Fasthosts

Resolved

Power has been restored and the majority of our agents are now back online.

Wait times may still be longer than expected until we have worked through any queued calls.
Posted Mar 24, 2025 - 12:21 GMT

Investigating

A power outage in Gloucester is currently affecting our UK office.

As a result there are currently fewer support agents available and wait times may be longer than expected.
Posted Mar 24, 2025 - 10:48 GMT