Websites unresponsive

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 12:07 GMT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 11, 2025 - 10:47 GMT

Investigating

Some websites on our shared web hosting platforms are currently unresponsive. Our engineers are aware of this issue and working on it as a priority.
Posted Feb 11, 2025 - 10:45 GMT
This incident affected: Hosting (Webhosting).