Cloud Panel and Server Provisioning unavailable

Incident Report for Fasthosts

Resolved

The issue has been resolved.
Posted Jul 10, 2026 - 06:39 BST

Monitoring

The CloudPanel is now working.
Posted Jul 10, 2026 - 04:06 BST

Identified

Due to an incident at one of our datacentres certain services are currently unavailable. In particular, the CloudPanel is offline and provisioning of new Cloud servers will be delayed.
Existing servers should continue to operate normally.
Engineers are working to get services back online but this is likely to take some time.
Posted Jul 10, 2026 - 01:15 BST
This incident affected: Control Panels (CloudNX Control Panel) and Servers (Cloud Servers).