Outage - Microsoft Exchange Platform

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Nov 12, 2025 - 11:15 GMT

Identified

We are investigating login issues affecting our hosted Microsoft Exchange platform. Customers attempting to log in using the URL https://webmail.livemail.co.uk/ will receive an error. Our Exchange administrators are working to resolve this critical incident now. For the meantime, you may use this URL https://exchange.livemail.co.uk/ on accessing your Microsoft Exchange emails.
Posted Nov 12, 2025 - 10:32 GMT
This incident affected: Email (Microsoft Exchange Email).