Webmail login errors

Incident Report for Fasthosts

Resolved

This incident has now been resolved.
Posted Feb 05, 2025 - 08:31 GMT

Investigating

We are currently investigating an issue causing webmail logins to fail. Some customers may be presented with an internal error when trying to access webmail.livemail.co.uk.

Our engineers are investigating this issue as a priority.
Posted Feb 05, 2025 - 08:08 GMT
This incident affected: Email (Webmail Interface).