Receiving emails may not be possible for some customers

Incident Report for Fasthosts

Resolved

The issue has been resolved. Our apologies for the inconvenience caused.
Posted Nov 04, 2025 - 11:30 GMT

Identified

Some customers may be experiencing issues receiving E-mails. We are working on a quick solution and apologise for any inconvenience this may cause.
Posted Nov 04, 2025 - 11:14 GMT
This incident affected: Email (Receiving Mail).