Service Outage - Webmail Unavailable

Incident Report for Fasthosts

Resolved

This incident is now resolved.
Posted Oct 29, 2025 - 13:25 GMT

Identified

We are aware that our Webmail interface is currently unavailable. Customers attempting to log in may receive an error. Accessing email via desktop or mobile clients (IMAP/POP3) is unaffected. Our team is working to restore the Webmail service now.
Posted Oct 29, 2025 - 12:56 GMT
This incident affected: Email (Webmail Interface).