Reduced Phone Availability
Incident Report for Fasthosts
Resolved
This incident has been resolved.
Posted Mar 16, 2024 - 13:16 GMT
Monitoring
Our engineers have identified the cause of the issue and implemented a fix. They will continue to monitor the platform.

All agents are available again and call queues and wait times now look to be within expected ranges.
Posted Mar 15, 2024 - 14:31 GMT
Investigating
Our engineers are currently investigating an on site issue in our call centres.

As a result of this issue a reduced number of agents are available on the phone and call wait times may be longer than expected.

Whilst the issue is ongoing we recommend raising a ticket on our Support Site or emailing us at support@fasthosts.com for non-urgent issues.
Posted Mar 15, 2024 - 14:05 GMT
This incident affected: Customer Services (Phone Systems).