Service Outage - Website Builder Unavailable

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 18:16 GMT

Identified

Our Website Builder platform is currently unavailable. Customers may not be able to log in to the editor or make changes, and the publishing function is offline. We are investigating the cause of this outage.
Posted Dec 16, 2025 - 17:19 GMT
This incident affected: Hosting (Website Builders).