Server Control Panel Error 20

Incident Report for Fasthosts

Resolved

This incident has been resolved.
Posted Apr 08, 2025 - 10:16 BST

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 10:16 BST

Update

We are continuing to investigate this issue.
Posted Apr 08, 2025 - 09:26 BST

Investigating

Customers are seeing Error 20 when trying to access the Control Panel area or CloudNX control panel for their servers. Our engineers are aware of the issue and are working on it as a priority.
Posted Apr 08, 2025 - 09:10 BST
This incident affected: Control Panels (Control Panel, CloudNX Control Panel).