Payment Gateway Issue

Incident Report for Fasthosts

Resolved

The issue affecting our payment gateway has now been resolved.
Posted Jun 04, 2025 - 14:43 BST

Investigating

We are currently experiencing an issue with our payment provider, payments and renewals may fail when attempting purchases on your Fasthosts account.

We are investigating this issue as a priority and hope to have this resolved shortly.
Posted Jun 04, 2025 - 14:28 BST
This incident affected: Account Administration (Payments and Billing).